using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"charset=""*(.*?)""+";
string input = @"<meta content=""text/html; charset=UTF-8"" http-equiv=""Content-Type"">
<meta charset=""UTF-8"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}