$re = '/charset="*(.*?)"+/m';
$str = '<meta content="text/html; charset=UTF-8" http-equiv="Content-Type">
<meta charset="UTF-8">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);