package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(hen)\/in-.+?\/day[^/]*?$`)
var str = `https://chillisauce.com/hen/in-dublin/day`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}