re = /\/(hen)\/in-.+?\/day[^\/]*?$/
str = 'https://chillisauce.com/hen/in-dublin/day'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end