const regex = /[^(]+\([^)]*\)\K.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^(]+\\([^)]*\\)\\K.*', 'gm')
const str = `[TEXT1] TEXT EXAMPLE HERE (ROBERT_01) MORE TEXT HERE POSSIBLY SOME NUMBERS 9999 THEN TEXT (JIMBO_01)
[TEXT1] TEXT EXAMPLE HERE () MORE TEXT HERE POSSIBLY () ()SOME NUMBERS 9999 () THEN TEXT (JIMBO_01)
Test (test) test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}