$re = '/[^(]+\([^)]*\)\K.*/m';
$str = '[TEXT1] TEXT EXAMPLE HERE (ROBERT_01) MORE TEXT HERE POSSIBLY SOME NUMBERS 9999 THEN TEXT (JIMBO_01)
[TEXT1] TEXT EXAMPLE HERE () MORE TEXT HERE POSSIBLY () ()SOME NUMBERS 9999 () THEN TEXT (JIMBO_01)
Test (test) test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);