package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z]{1}[a-zA-z0-9]{1,15}$`)
var str = `nikhil11 , 11nikhil`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}