$re = '/^[a-zA-Z]{1}[a-zA-z0-9]{1,15}$/';
$str = 'nikhil11 , 11nikhil';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);