using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\sfor\s(?:invalid\suser\s)?(?<Username>\w+)\s\w+\s(?<IP>[^\s]+)";
string input = @"Thu Sep 07 2021 00:15:06 mailsv1 sshd[2605]: Failed password for invalid user itmadmin from 194.8.74.23 port 4692 ssh2
Thu Sep 07 2021 00:15:06 mailsv1 sshd[3759]: Failed password for nagios from 194.8.74.23 port 3769 ssh2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}