package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s+(.*?)\s+[A-Z](https?:\/\/\S+)\s+(.*)$`)
var str = `1cb07348-34a4-4741-b50f-c41e584370f7 TeamSpeak Addon Author Vhttps://badges-content.teamspeak.com/1cb07348-34a4-4741-b50f-c41e584370f7/addon_author Creator of TeamSpeak Addons`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}