re = /^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s+(.*?)\s+[A-Z](https?:\/\/\S+)\s+(.*)$/m
str = '1cb07348-34a4-4741-b50f-c41e584370f7 TeamSpeak Addon Author Vhttps://badges-content.teamspeak.com/1cb07348-34a4-4741-b50f-c41e584370f7/addon_author Creator of TeamSpeak Addons'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end