#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([-+]?((\d*\.\d+)|(\d+))([eE][-+]?\d+)?)"
Local $sString = ", , , \n 62.5,-8.0-.9-.45-.39, , , .8654098.9-849.7849727799997-58.02000000000001,\rM-849.7849727799997 54.375 , \t\r-846.1399727799996-54.375-846.1399727799996-54.375,.9-.90-7-841.6599727799997-54.375,-837.1799727799998-58.02000000000001, t0,-833.5349727799997-62.5,-833.5349727799997-66.97999999999997,\n-833.5349727799997-70.625,-837.1799727799998-70.625,-841.6599727799997-70.625,\r-846.1399727799996-66.98,-849.7849727799997-62.5,-849.7849727799997"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")