import re
regex = re.compile(r"([-+]?((\d*\.\d+)|(\d+))([eE][-+]?\d+)?)")
test_str = ", , , \\n 62.5,-8.0-.9-.45-.39, , , .8654098.9-849.7849727799997-58.02000000000001,\\rM-849.7849727799997 54.375 , \\t\\r-846.1399727799996-54.375-846.1399727799996-54.375,.9-.90-7-841.6599727799997-54.375,-837.1799727799998-58.02000000000001, t0,-833.5349727799997-62.5,-833.5349727799997-66.97999999999997,\\n-833.5349727799997-70.625,-837.1799727799998-70.625,-841.6599727799997-70.625,\\r-846.1399727799996-66.98,-849.7849727799997-62.5,-849.7849727799997"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")