package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((00|\+)(32)(\d{9}))$`)
var str = `1-AAA-123
AAA-000
+32468533830
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}