import re
regex = re.compile(r"^((00|\+)(32)(\d{9}))$", flags=re.MULTILINE)
test_str = ("1-AAA-123\n"
"AAA-000\n"
"+32468533830\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")