import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "table[12]\\d";
final String string = "table id='table19'><tr></tr></table>\n"
+ "<table id='table20'><tr></tr></table>\n"
+ "<table id='table21'><tr></tr></table>\n\n"
+ "<table id='table40'><tr></tr></table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}