import re
regex = re.compile(r"table[12]\d", flags=re.MULTILINE)
test_str = ("table id='table19'><tr></tr></table>\n"
"<table id='table20'><tr></tr></table>\n"
"<table id='table21'><tr></tr></table>\n\n"
"<table id='table40'><tr></tr></table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")