package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\([1-9]{3}\)\s{1}[0-9]{3}-[0-9]{4}$`)
var str = `(111) 111-1111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}