const regex = /^\([1-9]{3}\)\s{1}[0-9]{3}-[0-9]{4}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\([1-9]{3}\\)\\s{1}[0-9]{3}-[0-9]{4}$', 'g')
const str = `(111) 111-1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}