const regex = /\b(hyd)(?:\s|$|[^\w])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(hyd)(?:\\s|$|[^\\w])', 'gi')
const str = `HYD. CYLINDER
HYD CYLINDER
HYD.CYLINDER
HYDRAULIC CYLINDER
CYLINDER,HYD.
CYLINDER,HYDRAULIC
CYLINDER,HYD
CYLINDER, HYD.
CYLINDER, HYDRAULIC
CYLINDER,HYD
`;
const subst = `HYDRAULIC`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);