// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'([^'\\]*(?:\\.[^'\\]*)*)'").unwrap();
let string = "[(u'apple',), (u'banana',)]
[(u'apple',), (u'banana',), (u'abc\\'def',)]
\\\\'abc''def'
\\\\\\'abc 'abc\\\\\\\\\\'def'
|- CORRECT-|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}