const regex = / TH (\d*) SP ([0-9-]*) (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' TH (\\d*) SP ([0-9-]*) (.*)', 'gm')
const str = `22303 - ALDEN, TH 46 SP 2481-62 PETER BUYI`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}