$re = '/ TH (\d*) SP ([0-9-]*) (.*)/m';
$str = '22303 - ALDEN, TH 46 SP 2481-62 PETER BUYI';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);