package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\w+):\s*([^][]*)]`)
var str = `[NAME: abc] [EMAIL: cde] [TIMEFRAME: efg] [BUDGET: hij] [MESSAGE: klm]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}