re = /\[(\w+):\s*([^][]*)]/m
str = '[NAME: abc] [EMAIL: cde] [TIMEFRAME: efg] [BUDGET: hij] [MESSAGE: klm]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end