package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w!#$%&'*+/=?^_`{|}~-]+(?:\.[\w!#$%&'*+/=?^_`{|}~-]+)*@(?:[\w](?:[\w-]*[\w])?\.)+[\w](?:[\w-]*[\w])?`)
var str = `zhuzhi@mail.ustc.edu.cn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}