re = /[\w!#$%&'*+\/=?^_`{|}~-]+(?:\.[\w!#$%&'*+\/=?^_`{|}~-]+)*@(?:[\w](?:[\w-]*[\w])?\.)+[\w](?:[\w-]*[\w])?/
str = 'zhuzhi@mail.ustc.edu.cn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end