import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(TC_)_?(\\d+).*";
final String string = "TC__6493_8exp\n"
+ "TC__6494_8exp\n"
+ "TC_6493\n"
+ "TC_6494\n"
+ "TC_6495....";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}