$re = '/^(TC_)_?(\d+).*/m';
$str = 'TC__6493_8exp
TC__6494_8exp
TC_6493
TC_6494
TC_6495....';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;