re = /^(.*?(?:@heroImageURL\s*=\s*""[^""]+"".*?){1}@heroImageURL\s*=\s"")[^""]+(?="")/
str = ' IF @brandName == "A" THEN
set @heroImageURL = "http://www.image.com/a9230239u230.jpg"
set @productImageURL = "http://www.image.com/A29200923.jpg"
ELSEIF @brandName == "B" THEN
set @heroImageURL = "http://www.image.com/b2389823u238.jpg"
set @productImageURL = "http://www.image.com/B22392029.jpg"
ELSEIF @brandName == "C" THEN
set @heroImageURL = "http://www.image.com/c23892389289.jpg"
set @productImageURL = "http://www.image.com/C49309934.jpg"
ELSEIF @brandName == "D" THEN
set @heroImageURL = "http://www.image.com/d23423892833.jpg"
set @productImageURL = "http://www.image.com/D09349409.jpg"
ELSEIF @brandName == "E" THEN
set @heroImageURL = "http://www.image.com/e22823889899.jpg"
set @productImageURL = "http://www.image.com/E22092309.jpg"
ELSE
set @heroImageURL = "http://www.image.com/e22823889899.jpg"
set @productImageURL = "http://www.image.com/E22092309.jpg"
ENDIF'
subst = '$1http://www.google.com/1.jpg'
result = str.sub(re, subst)
# Print the result of the substitution
puts result