package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Dim\s?(WithEvents)?\s([\S]*)(\(\))?(?:\s)?(?:As)?\s?(New)?\s?([\S]*)`)
var str = `Dim WithEvents ueu As String`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}