$re = '/Dim\s?(WithEvents)?\s([\S]*)(\(\))?(?:\s)?(?:As)?\s?(New)?\s?([\S]*)/m';
$str = 'Dim WithEvents ueu As String';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);