#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*((?(?<=^)|(?<=:))test(?=(:|$))).*(?1)).+$"
Local $sString = "test:avaas" & @CRLF & _
"test:test:asaac" & @CRLF & _
"asdaf:test:asda" & @CRLF & _
"asd:test:asda:test:asd" & @CRLF & _
"asd:test:test:asd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")