$re = '/^(?!.*((?(?<=^)|(?<=:))test(?=(:|$))).*(?1)).+$/m';
$str = 'test:avaas
test:test:asaac
asdaf:test:asda
asd:test:asda:test:asd
asd:test:test:asd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);