$re = '/(?i)(:s|usa|what)/m';
$str = 'What is your least favorite thing about living in the USA?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);