package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\W\d][\w-]*$`)
var str = `hello world
_Sau90-jds
5_idsjd
A-next`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}