$re = '/^[^\W\d][\w-]*$/m';
$str = 'hello world
_Sau90-jds
5_idsjd
A-next';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);