$re = '/(.*?):(.*?)(?:,|$)/m';
$str = 'a_key : a_value, b_key: b_value, c_key: c_value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);