re = /(.*?):(.*?)(?:,|$)/m
str = 'a_key : a_value, b_key: b_value, c_key: c_value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end