package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(\d+)$`)
var str = `asdf-1
asdf12
adf0
asdfasdf
asdf-1293012`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}