$re = '/^.*(\d+)$/m';
$str = 'asdf-1
asdf12
adf0
asdfasdf
asdf-1293012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);