$re = '/ATS-[0-9]{7}/mi';
$str = 'ATS-0123456
ats-0123456
Ats-2333333
aTs-2525252';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);