re = /^(?!.*\[\s*\])[a-zA-Z0-9_\-\[\] ]*$/m
str = 'Your message here
Your [text] message here
your_text_message [text]
Your [] message here
[] message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end