package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(*UCP).*\bпроверка\b.*`)
var str = `а проверка б`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}