$re = '/(*UCP).*\bпроверка\b.*/m';
$str = 'а проверка б';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);