#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*\.Name.*)\s+(?!.*\.Surname)"
Local $sString = "blahblahblah.Name=qwqwqwqwqw" & @CRLF & _
"abracadabra.Surname=ererererer" & @CRLF & _
"zxzxzxzxzx.Name=kmkmkmkmkmkm" & @CRLF & _
"oioioioi.Name=dfdfdfdfdfdf" & @CRLF & _
"popopopopopopo.Surname=lklklklklklklk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")