re = /^(.*\.Name.*)\s+(?!.*\.Surname)/m
str = 'blahblahblah.Name=qwqwqwqwqw
abracadabra.Surname=ererererer
zxzxzxzxzx.Name=kmkmkmkmkmkm
oioioioi.Name=dfdfdfdfdfdf
popopopopopopo.Surname=lklklklklklklk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end