using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<eventtimestamp>[\d:. -]+)\|(?<TYPE>[a-zA-Z]+)\|(?<LOGLEVEL>[a-zA-Z]+)\|(?<IPaddress>[\d.]+)\|(?<HOSTNAME>[^|]+)\|(?<message>.*)$";
string input = @"2016-10-21 01:10:27.513|main|INFO|125.0.225.25|gdtl01db7i7h|{""instanceName"":""testinstance"",""applicationId"":""ABS3PP"",""transactionStatus"":""C"",""responseCode"":""0"",""responseDescription"":""Success"",""initiatedTimestamp"":""2016-09-19 00:00:00.0"",""elapsedTime"":""44400.0"",""clientApp"":""ServiceGateway~368"",""clientIp"":""35.23.89.235"",""cluster"":""P27C"",""httpMethod"":""POST"",""requestURL"":""/test/ctn""}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}