# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<eventtimestamp>[\d:. -]+)\|(?<TYPE>[a-zA-Z]+)\|(?<LOGLEVEL>[a-zA-Z]+)\|(?<IPaddress>[\d.]+)\|(?<HOSTNAME>[^|]+)\|(?<message>.*)$"
test_str = "2016-10-21 01:10:27.513|main|INFO|125.0.225.25|gdtl01db7i7h|{\"instanceName\":\"testinstance\",\"applicationId\":\"ABS3PP\",\"transactionStatus\":\"C\",\"responseCode\":\"0\",\"responseDescription\":\"Success\",\"initiatedTimestamp\":\"2016-09-19 00:00:00.0\",\"elapsedTime\":\"44400.0\",\"clientApp\":\"ServiceGateway~368\",\"clientIp\":\"35.23.89.235\",\"cluster\":\"P27C\",\"httpMethod\":\"POST\",\"requestURL\":\"/test/ctn\"}"
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.