using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([{\[(""']\w+[}\])""'])|(\w+))";
string input = @"word1{word2}[word3](word4)""word5""'word6'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}